Shopware Login Problem

Shopware Login Problem

veröffentlicht am 08.07.2017

Bei der Entwicklung eines Shopware Onlineshops ist mir nach dem Update von Version 5.3 RC auf 5.3 ein interessanter Fehler aufgefallen. Ein "normales" Login in das Backend wie vorher war nicht mehr möglich. Stattdessen quittierte Shopware nach erfolgreicher Prüfung der Zugangsdaten den Loginvorgang mit einer "diese Seite funktioniert nicht" Meldung ohne einen weiteren Hinweis, wo denn eigentlich ein Fehler aufgetreten ist.

Shopware Login Fehler

Shopware Login Fehler

Was folgte, waren zeitaufwändige Recherchen im Internet. Schließlich enthielt ein Beitrag im Netz einen entscheidenden Hinweis (Beitrag bei Netinventors). So ist es wohl schon desöfteren aufgetreten, dass es beim Login in das Backend im Zusammenhang mit der Lokalisierung Probleme mit dem sog. "SHOPWAREBACKEND" Cookie geben kann.

Shopware SHOPWAREBACKEND Cookie

Shopware SHOPWAREBACKEND Cookie


Dieses Hinweis führte in meinem Fall zur Lösung. Ich habe dieses Cookie per Hand gelöscht. In diesem Fall lädt sich die Loginseite in das Backend ohne Fehler. Nun im Dropdown des Logindialogs die englische Sprache ausgewählt und tatsächlich: der Login ist erfolgreich.

Shopware Backend Login mit englischer Sprachauswahl

Shopware Backend Login mit englischer Sprachauswahl

Allerdings sind nach diesem Login die Menüeinträge im Backend bunt gemischt in DE und EN. Nun ja, erstmal besser als eine weiße, nichts aussagende Fehlerseite.

 

Shopware Backend Menüeinträge in englischer Sprache

Shopware Backend Login mit englischer Sprachauswahl

 

Shopware Login Problem

Shopware Login Problem